Add Target Fixer

Fixes the security issue with target="_blank".

Author:Neil Ludlow (profile at wordpress.org)
WordPress version required:3.5
WordPress version tested:5.8.10
Plugin version:0.0.04
Added to WordPress repository:17-09-2016
Last updated:03-11-2021
Warning! This plugin has not been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.
Rating, %:100
Rated by:3
Plugin URI:https://shortdark.co.uk/projects/add-target-f...
Total downloads:2 088
Active installs:100+
plugin download
Click to start download

This plugin looks at the phishing issue with target=”_blank” vulnerability when the opened page can control the referring page.
The plugin fixes it by adding a rel=”noopener noreferrer” in the “A” tags where a target=”_blank” is found. It does not
change the content, it only modifies the “A” tags while the plugin is active. Tested on PHP 5 to PHP 8.

Please let me know if you like this plugin by leaving a review or contacting me.

Go to the Shortdark WordPress plugin page for more information.


ChangeLog