Arevico Security Basic

The fundamentals of securing your website. We believe in fixing security issues at the root, while keeping user convenience high.

Author:Arevico (profile at wordpress.org)
WordPress version required:3.0
WordPress version tested:3.8
Plugin version:1.0
Added to WordPress repository:14-08-2013
Last updated:12-12-2013
Warning! This plugin has not been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.
Rating, %:0
Rated by:0
Plugin URI:http://wordpress.org/plugins/arevico-security...
Total downloads:823
plugin download
Click to start download

The fundamentals of securing your website. We believe in fixing security issues at the root, while keeping user convenience high. Arevico basic security helps you by:

  • requiring associated email to use as a login username
  • Enforce strong password
  • Enforce reset of weak passwords
  • Enforce password expiration after a specified amount of days
  • Hide or customize login error message
  • Lockout an account after too may failed login attempts
  • Send an email with a reset link to the email associated with the locked account.

You can determine which options you want to set in the admin menu.

Requirements

  • PHP5
  • Network site compatible

We plan on adding more security features. So be sure to contact us if you have a great idea.


Screenshots
FAQ